New Feature - Customizable Explore Dropdown Menu

Monday, February 1, 2010 by Kestral2040 | Discussion: WinCustomize 2011 Feedback

I finished the feature I was talking about in another post...   if you are a subscriber you should now have a customize option in the explore menu.  This will allow users to pick which libraries they want showing up on in their personal menu.   This is saved on an account level so once you change it it will be that way any time you login until you change it again.  Again this is for subscribers only so I made a video for those who aren't subscribers but would like to see what it looks like, you can find that here

 

sorry for having no narration, I don't have a mic.   Basically I just turn on and off some libraries a couple times and then show what the default view is for non-subscribers/people not logged in. 

 

If people have any technical issues with it let me know.

 

made this second post to make sure people see this.

DrJBHL
Reply #1 Monday, February 1, 2010 7:16 PM

Kestral...thanks! This is a great feature! 

gmc2
Reply #2 Monday, February 1, 2010 7:43 PM

you're doing a great job, many thanks.

gmc2
Reply #3 Monday, February 1, 2010 7:53 PM

I just went to customise this and I can't advance past a certain point. notice that the drag bar is all the way down but the list is still at the top?

Frogboy
Reply #4 Monday, February 1, 2010 7:58 PM

Which browser you using?

ZubaZ
Reply #5 Monday, February 1, 2010 8:02 PM

Gotta love Jing. 

 

Great feature!

gmc2
Reply #6 Monday, February 1, 2010 8:17 PM

Which browser you using?

ie7 and with cookie restrictions although I have exceptions for both wc and wctest. I am customised on the current set-up, not the beta.

karmat
Reply #7 Monday, February 1, 2010 8:31 PM

Thanks, the site is coming along nicely!

PurrBall
Reply #8 Monday, February 1, 2010 9:10 PM

The Customize feature has been there for ages for everyone, why only subscribers now?

Kestral2040
Reply #9 Tuesday, February 2, 2010 11:20 AM


Which browser you using?
ie7 and with cookie restrictions although I have exceptions for both wc and wctest. I am customised on the current set-up, not the beta.

I'm going to look into it in IE7, its probably a plugin issue, it shouldn't be anything cookie related

 

wow so I don't know why exactly its doing this in IE7, however, I noticed that if you scroll down then hover over the close or save buttons it suddenly adjusts the window to be in the right spot....  I'm going to try and find a fix for this, it must be something with the plugin not liking IE7, however, in the mean time you can use that trick to at least use the menu for now. 

update1:

Also there were some general bugs in the menu I think I've ironed out, you still may have issues if you have changed your options a couple times already, I'm going to wipe the database in a little so you will have to reset them (should fix the problems going forward hopefully).  This shouldn't be something that happens regularly

update2:

I think I fixed the problems with the customize menu on the backend without having to wipe the database.  Yay, unfortunately the IE7 issue I still haven't figured out.

PurrBall
The Customize feature has been there for ages for everyone, why only subscribers now?

which ties into this...   I cant say every reason why its subscriber only but for one thing this system is more robust than the old one.  The old system was cookie based which means if you had cookie clearing after every browser system or logged in on multiple computers you would have to set it every time.  Also if multiple people logged in on one computer they would have the same setting ect.  This new system is database based, your information is stored onto your account on our servers.

GhoS
Reply #10 Tuesday, February 2, 2010 7:31 PM

It isn't working right for me for some reason.  First I went into customize  and saved it and nothing changed.  Then I decided I'll click Home and re-load the page basically.  I went into customize again and after I saved it showed only CursorFX but I had selected several other things as well.

Tried it one more time and the same thing. 

On Win7 using Firefox 3.6   If it ends up working I'll let you know, but so far no luck. 

 

It figures I went back again to try it after I made the reply and the customization had worked!!  It might still be a slight bug that the changes do not show right away, I don't know.

Wizard1956
Reply #11 Tuesday, February 2, 2010 7:59 PM

I selected 10 galleries to show but after saving,it  unchecks some items and checks some that I had not selected or rechecks some that I had unchecked. I've tried multiple times(at least 10) and the programs it adds to the list varies,but SoundPackager,Desktop Suites and LogonStudio reappear most often.

I also get "There has been an error........." on attempting to save occasionally.

Oops..forgot to say Win7 and IE8.

RedneckDude
Reply #12 Tuesday, February 2, 2010 8:05 PM

I get the same as Wizard, only one difference. I also get sent to a user's profile every time I click save after customizing...lol..  This is twilight zone stuff...lol.

This is where it takes me when I click save:

Wizard1956
Reply #13 Tuesday, February 2, 2010 8:06 PM

It figures I went back again to try it after I made the reply and the customization had worked!! It might still be a slight bug that the changes do not show right away, I don't know.

That makes two of us. The changes seem to have stuck this time.

gmc2
Reply #14 Tuesday, February 2, 2010 9:09 PM

just attempted again and pretty much the same thing. I did the hover suggestion to no avail???

Kestral2040
Reply #15 Wednesday, February 3, 2010 10:22 AM

ok I'm looking into all these issues...   the pain is that it seems to not always behave the same way  hard to diagnose....  for you guys that are having problems, next time you have an issue with it can you try doing a control f5 refresh (clearing your cache), if it shows up right then its probably a caching issue (which hopefully I can fix), otherwise its somewhere on the server.

 

update:  ok after looking into this I think I've partially fixed what was wrong with it.   For those curious there were issues with caching on the database side.  I'm pretty sure its working now, however, I still haven't been able to fix that IE7 issue...

Please login to comment and/or vote for this skin.

Welcome Guest! Please take the time to register with us.
There are many great features available to you once you register, including:

  • Richer content, access to many features that are disabled for guests like commenting on the forums and downloading skins.
  • Access to a great community, with a massive database of many, many areas of interest.
  • Access to contests & subscription offers like exclusive emails.
  • It's simple, and FREE!



web-wc01