Stardock Site gives Incorrect Product Key

Monday, May 26, 2014 by sViz | Discussion: Stardock Support General

In My Account > My Downloads on the main Stardock site, the product key for my DesktopX is incorrect. The last block of numbers is completely different from the one I saved from original purchase (which is correct and works.)

Anyone else have this issue?

RedneckDude
Reply #1 Monday, May 26, 2014 12:34 AM

Oddly, DesktopX never asks me for a key, but I  haven't saved any on my PC, so I dunno.

 

Sorry.   Good to see you here, Eve.

MeSleeper
Reply #2 Monday, May 26, 2014 12:50 AM

I just compared the S/N that I saved with the S/N on My Downloads.   They do not match.   I did not try to install.

sViz
Reply #3 Monday, May 26, 2014 12:53 AM

Hey Jim. How are you?

I'm reinstalling, so I needed the key. Thought I'd use the handy info on my account, instead of pulling out my thumbdrive but nope.

 

LightStar
Reply #4 Monday, May 26, 2014 9:29 AM

Just checked all mine at the store and they are the same as I have here backed up. Better send an email to support Eve. 

RedneckDude
Reply #5 Monday, May 26, 2014 11:44 AM

Eve, are you using Pro, or just the regular version. Pro never asks for a key, even on a fresh install/reinstall.

I guess I should be backing up my serials.

sViz
Reply #6 Monday, May 26, 2014 12:34 PM

Thanks for the replies. I just sent an email. Yes, I'm using pro 3.5 and it always asks me for the key on reinstall.

RedneckDude
Reply #7 Monday, May 26, 2014 1:22 PM

Ah, I forgot, I am using Pro Beta 4 (3.96)  ( No longer available) My bad.

MeSleeper
Reply #8 Monday, May 26, 2014 2:09 PM


Thanks for the replies. I just sent an email. Yes, I'm using pro 3.5 and it always asks me for the key on reinstall.

Eve - if you think about, I'd be be interested in knowing what TS has to say.  Since I have my saved S/N, I'm confident I can install version 3.5 again if I need to.  When I switched from 32 bit XP to 64 bit Win 7 Pro, DesktopX stopped working properly for me.   I suspect there are ways to work around that, but I just moved on with the anticipation and hope a new release would be forthcoming.  Someday I may try again.

Sleep 

 

sViz
Reply #9 Monday, May 26, 2014 2:27 PM

Yeah, I didn't backup my updates (3.9, etc) so when Impulse was gone so were they. MeSleep, I'll let y'all know what I hear.

sViz
Reply #10 Monday, June 2, 2014 7:49 PM

Support sorted out the issue. If you have incorrect info on your account, it seems, your only hope is to have the original info saved somewhere. You'd have to notify them with the correct info so they can update your account.

MeSleeper
Reply #11 Monday, June 2, 2014 10:25 PM


Support sorted out the issue. If you have incorrect info on your account, it seems, your only hope is to have the original info saved somewhere. You'd have to notify them with the correct info so they can update your account.

 

Thanks sViz.  I have my S/N backed up a few places so no need to waste TS' time.  I'm not sure if DesTopX 3.5 works on 64 bit Win 7 anyway.  I can't get it to work, but I believe I read somewhere that others have had some success.   Those folks may be using one of the higher beta versions that I never downloaded. I truly appreciate you coming back to share this information.  Not many folks would have been so courteous to do so

Please login to comment and/or vote for this skin.

Welcome Guest! Please take the time to register with us.
There are many great features available to you once you register, including:

  • Richer content, access to many features that are disabled for guests like commenting on the forums and downloading skins.
  • Access to a great community, with a massive database of many, many areas of interest.
  • Access to contests & subscription offers like exclusive emails.
  • It's simple, and FREE!



web-wc01