Modding pre-7 skin to fit taller taskbar buttons

Monday, August 8, 2011 by Bebi Bulma | Discussion: Skinning

I'm using some older skins that were made for XP and an unfortunate issue has come up...the buttons aren't stretching vertically to accommodate the larger taskbar. What setting do I need to adjust to make the buttons stretch properly? Thanks.

Xiandi
Reply #1 Monday, August 8, 2011 10:11 PM

I think it may depend on what skin it is. I would think that most of the time you will need to just change the painting margins on the buttons, maybe set it to stretch and tweak them a bit. If you let me know which skins, I can fiddle with them and tell ya what needs to be done.

 

Bebi Bulma
Reply #2 Monday, August 8, 2011 10:14 PM

Was actually messing with AlienMorph for like the first time in 7 years. I know Black by tehzer0 does it too...wish someone would update that one to 7.

Xiandi
Reply #3 Monday, August 8, 2011 11:05 PM

For Black by tehzer0, set the taskbar button painting margins to 12, 13, 12, 12. That should fix it for you.

Got a link to the Alienmorph skin? I can't seem to find it, unless you are talking about the Alienware Xenomorph skin ... and I am not seeing this problem with that one.

Bebi Bulma
Reply #4 Monday, August 8, 2011 11:16 PM

Should be this one, the preview looks to be missing. https://www.wincustomize.com/explore/windowblinds/4471/

Actually....I'm not sure where a download is anymore.

 

Those margins didn't seem to help on Black....

DaveRI
Reply #5 Monday, August 8, 2011 11:18 PM

Increasing the buttons / text top and bottom margins might get it if the painting margins don't.

Xiandi
Reply #6 Monday, August 8, 2011 11:30 PM

Bebi Bulma
Those margins didn't seem to help on Black....
Did for me when I did it....I don't know why it isn't for you.

The download button for the Alienmorph skin takes you to a different website. Not sure I want to download a huge file just to see the windowblind.

Bebi Bulma
Reply #7 Monday, August 8, 2011 11:39 PM

Yeah and I don't even know if the huge installer is even still there.

As for Black, I tried applying the theme without saving it first, hoping that would actually just apply the changes, but apparently SKS doesn't actually want to do what it says it's going to do. Have to save it before it will apply any changes, but it looks to have worked.

Got the button to stretch vertically, now the icon is covering the special left portion of the image.....the saga continues.

 

 

Xiandi
Reply #8 Tuesday, August 9, 2011 12:00 AM

Bebi Bulma
now the icon is covering the special left portion of the image
You're not gonna be able to fix that. The way to fix it SHOULD be by increasing the left and right text margins on the buttons, but those margins do not work at all in W7.

Bebi Bulma
Reply #9 Tuesday, August 9, 2011 12:11 AM

Of course. Even using small icons doesn't fix it....stupid Windows.

Thanks for the other stuff.

Xiandi
Reply #10 Tuesday, August 9, 2011 12:12 AM

Sure thing

gmc2
Reply #11 Tuesday, August 9, 2011 7:14 AM

Bebi Bulma
As for Black, I tried applying the theme without saving it first, hoping that would actually just apply the changes, but apparently SKS doesn't actually want to do what it says it's going to do. Have to save it before it will apply any changes, but it looks to have worked.

that's really sop and generally when altering internal settings (margins and such) it should prompt you for a save before it will apply.

DaveBax
Reply #12 Tuesday, August 9, 2011 8:16 AM

Quoting Bebi Bulma, reply 7As for Black, I tried applying the theme without saving it first, hoping that would actually just apply the changes, but apparently SKS doesn't actually want to do what it says it's going to do. Have to save it before it will apply any changes, but it looks to have worked.

that's really sop and generally when altering internal settings (margins and such) it should prompt you for a save before it will apply.

Greg it always promps you however. sks can be a strange bird when it wants to. I have made changes and know it was changed. Even after saving and applting again it didn't show. Now and then I even have to reboot and it now will show. Several other things can go on also but as you know working with it you learn the strange things and just work with it. The sad part is a few tweaks and aditional changes added would make it really good. It works as is and that is the most important thing.

gmc2
Reply #13 Tuesday, August 9, 2011 11:04 AM

DaveBax
Greg it always promps you

Maybe my sks is flawed but when I just change a graphic, then click on "force image reimport" and then click on "apply skin" and it does not prompt me for a save. the prompt only happens when I change some numeric value, be it painting or text margins... at least that has been my experience. well, and a color change will always request a save before applying.

Xiandi
Reply #14 Tuesday, August 9, 2011 11:13 AM

Maybe my sks is flawed but when I just change a graphic, then click on "force image reimport" and then click on "apply skin" and it does not prompt me for a save.
Right. SKS asks for a save when you change something that has a value in the code. There is no need for it to ask for a save when you only reimport an image because the code is already there for it.

Please login to comment and/or vote for this skin.

Welcome Guest! Please take the time to register with us.
There are many great features available to you once you register, including:

  • Richer content, access to many features that are disabled for guests like commenting on the forums and downloading skins.
  • Access to a great community, with a massive database of many, many areas of interest.
  • Access to contests & subscription offers like exclusive emails.
  • It's simple, and FREE!



web-wc01