Bugs in ObjectDock

Tell me, show me.

Thursday, June 25, 2009 by messiah1 | Discussion: ObjectDock

As a faithful follower of Brother Jeff's Baby, ObjectDock is my mostest favorite SD program that sits on my PC.  I've noticed a few bugs along the way but at 1.9, how I use it, I've not had any real problems other than when I switch a WindowBlind I notice sometimes (not all the time) that the icons disappear or appear behind the dock.  A simple mouseover brings them back to the front.

 

However, I troll the ObjectDock forums quite a bit and two of the posts I keep tabs on have a bunch of people saying that it's buggy as hell and that they can't understand why SD hasn't fixed it yet.  Now I understand that OD doesn't work right in Vista 64 bit and that's been acknowledged by SD.  My question here is, what else have users experienced that they consider a bug.

 

I don't want to see something that you wish OD could do as in a feature request, if that's what you have, read through this post https://forums.wincustomize.com/167382 and if it isn't already there, post it.  I'm only looking for things that you consider a bug.  If you can, post a screenshot of the issue here with your bug.

 

My motivation for this is purely selfish, I'm a selfish guy.  I want to see what people are experiencing, and who knows, maybe this post will get the attention that my other post (link above) has.  I know Brother Jeff checks that one as well as a striped quad legged animal who happens to work at SD (lucky bastard) and can move things along to the Annointed One if he doesn't happen to stop in.  So...show me your bugs.

 

*EDIT- If you could, post what OS you are using.  ex. Vista Ultimate 64 bit

First Previous Page 3 of 3 Next Last
messiah1
Reply #41 Monday, July 27, 2009 11:39 AM

P.S. It would be nice of the SD chaps to drop in now and then and post a couple of lines about which bugs will be given a priority and update us on the development. After so long since 1.9, you can't blame people for being eager.

 

Agreed.

gcdlz
Reply #42 Wednesday, July 29, 2009 9:42 PM

There is a problem I was experiencing when using Vista 32bit, which I did not associate with Object Dock, until I started using Win7.  I was using Win7 for several weeks before I got around to installing Object Dock 1.9 Plus.  Upon installing Object Dock the same issue started happening that I had been experiencingin Vista.  Any time Object Dock is running, if I click a video file to play it, media player is minimized to the task bar and the icon must be clicked to see the video.  The same thing happens if I click a picture file to open in windows live photo gallery.  If I unload Object Dock the problem goes away.

Skinhit
Reply #43 Wednesday, July 29, 2009 10:06 PM

Well I dont have time to read all the other posts so I'm not sure if this has been stated already or not. I am running Vista 64bit which also has problems with IP and I guess now OD too...I have OD at the top of my screen and no windows or sidebar open full screen meaning they stop where OD starts....very frustrating!

messiah1
Reply #44 Thursday, July 30, 2009 7:05 AM

Well I dont have time to read all the other posts so I'm not sure if this has been stated already or not. I am running Vista 64bit which also has problems with IP and I guess now OD too...I have OD at the top of my screen and no windows or sidebar open full screen meaning they stop where OD starts....very frustrating!

 

Make sure the Reserve Edge of Screen box is unchecked.

Skinhit
Reply #45 Thursday, July 30, 2009 12:18 PM

silly me

messiah1
Reply #46 Thursday, July 30, 2009 2:01 PM

silly me

 

cas_01
Reply #47 Tuesday, August 4, 2009 8:17 PM

 

My problem is that every time I run Media Monkey OD crashes. I can't send a report because the "OD has to close" window won't let me get at the "save report" button. I'm running Vista, btw.

inc0gnito
Reply #48 Wednesday, August 19, 2009 4:38 AM
Upgraded to Windows 7 and found a variant of that Start Menu moving to bottom left-hand corner bug I mentioned in my first post in this thread. The difference in this variant is that when you click on the Start Menu orb and then hover over All Programs the whole menu jumps to the left. Grrr that's annoying...
inc0gnito
Reply #49 Thursday, August 20, 2009 1:31 PM

One more bug...

The way Windows Live Messenger is in Windows 7 taskbar has changed from the way it is in Windows Vista and OD+ isn't handling it properly because you can't right-click on the icon in the current tasks dock if WLM's main window was previously hidden via X button.

inc0gnito
Reply #50 Saturday, August 22, 2009 5:59 AM

Another bug that's related to the one above...

When closing Live Messenger, it's not shown in either taskbar dock or systray tab of another dock, yet a white triangle remains on its shortcut to indicate that it's currently running.

Please sort it out Stardock and quickly! Sigh...

Albert8839
Reply #51 Monday, August 24, 2009 12:07 AM

I have been using OD+ since it was first published, but I have suddenly found my icons won't display properly. Some will allow me to set new icons through object dock propersties, but other simply refuse to show the proper icon of exe files in the browser, and show only as text file icons.

Any suggestions on how I can fix it? Searching the net has come up a blank for me. Tried reseting the iconcache.db for vista, but that wasn't the problem.

I am running vista 64bit

Albert

inc0gnito
Reply #52 Tuesday, August 25, 2009 9:11 AM

One more bug, when will they be squashed? Sigh...

On an occasion the hover-over information for system tray would not be displayed when hovering over an icon in systray tabbed dock. For example, Windows Media Centre Client Maintenance Update.

inc0gnito
Reply #53 Friday, August 28, 2009 11:22 AM

Another bug that I just discovered, it has been a while since I seen it, but it's back!

If you have an external USB HDD and a dock with a Recycle Bin docklet, then when you delete something from that external HDD and empty your Bin by right-clicking on that docklet and selecting "Empty...", then on occasions the ObjectDock.exe locks onto your USB HDD and it becomes very difficult to Safely Remove it. My only remedies so far been Unlocker and LockHunter programs that unlock process handles off the HDD. That's very naughty behaviour by OD+, please fix it!

EDIT: added a screenshot of the window below:

inc0gnito
Reply #54 Friday, August 28, 2009 11:49 AM

nevermind...the forum software double-posted it

inc0gnito
Reply #55 Saturday, August 29, 2009 11:38 AM

Guess what?...One more bug has been found by yours truly!

Recycle Bin's status sometimes does not change correctly, i.e shows and reports as empty while it's not and vice versa.

Please login to comment and/or vote for this skin.

Welcome Guest! Please take the time to register with us.
There are many great features available to you once you register, including:

  • Richer content, access to many features that are disabled for guests like commenting on the forums and downloading skins.
  • Access to a great community, with a massive database of many, many areas of interest.
  • Access to contests & subscription offers like exclusive emails.
  • It's simple, and FREE!



web-wc01