Wallpaper On Second Monitor Does Not Load On Startup

Monday, April 15, 2019 by Lerem | Discussion: DeskScapes

Hi. Put simply, Deskscapes isn't applying the wallpaper on my second monitor when my computer is starting up.

  • SOMETIMES, when I start up my computer, the second monitor's wallpaper does show up.
  • NORMALLY I have to wait for the computer to finish starting up, then right click on the desktop to select "configure deskscapes". A few seconds after that window is brought up, the second wallpaper is applied.
  • RARELY the second wallpaper doesn't show up on it's own, and I have to manually apply a new wallpaper to the second monitor.

I'm just using static images, and haven't messed around with animated wallpapers or dreams at all yet. (My computer's on it's way out, and it's already starting to get a bit of slowdown.) I'm also not using any wallpaper randomization or any effects, tints, adjustments, or other special features. It's about as simple as it can get with the two wallpapers.

This is with version 8 installed.

I'm also subscribed to Object Desktop and have the following installed at the same time:

  1. Fences 3
  2. Groupy
  3. IconPackager v10
  4. SkinStudio 10
  5. SoundPackager
  6. Theme Manager
  7. Tweak7
  8. WindowBlinds 10
  9. WindowFX 6

Currently, I'm assuming I made a mistake somewhere in the setup.

Other issues I'm having that may be related are that SpaceMonger 3 isn't detected by the Object Desktop Manager as installed. It doesn't appear on the Installed list, only on the Manage list. Even directly after I install it.

Also, I think the login button at the top of the page on this website is a broken link. Clicking on it didn't do anything. I had to log in by going to the "sign up" link, and then clicking the "log in" link that was in the main part of the page.

I'm slowly working my way through the customization apps. I just need a day or two free from other demands on my time to really dig in to them.

First Previous Page 1 of 2 Next Last
basj
Reply #1 Monday, April 15, 2019 9:38 PM

Hello,

Sorry to hear you are having issues.


Hi. Put simply, Deskscapes isn't applying the wallpaper on my second monitor when my computer is starting up.

SOMETIMES, when I start up my computer, the second monitor's wallpaper does show up.
NORMALLY I have to wait for the computer to finish starting up, then right click on the desktop to select "configure deskscapes". A few seconds after that window is brought up, the second wallpaper is applied.
RARELY the second wallpaper doesn't show up on it's own, and I have to manually apply a new wallpaper to the second monitor.
I'm just using static images, and haven't messed around with animated wallpapers or dreams at all yet. (My computer's on it's way out, and it's already starting to get a bit of slowdown.) I'm also not using any wallpaper randomization or any effects, tints, adjustments, or other special features. It's about as simple as it can get with the two wallpapers.

This is with version 8 installed.

Have you tried the Deskscapes 10 beta yet. You should be able to download and test out DS10 beta2 via your account. https://store.stardock.com/myaccount/products or via OD manager if you enable that beta options in the setting.


Other issues I'm having that may be related are that SpaceMonger 3 isn't detected by the Object Desktop Manager as installed. It doesn't appear on the Installed list, only on the Manage list. Even directly after I install it.

This is known issue with current version of OD Manager. I believe its been look at and should be solve when the new OD manager come out soon.


Also, I think the login button at the top of the page on this website is a broken link. Clicking on it didn't do anything. I had to log in by going to the "sign up" link, and then clicking the "log in" link that was in the main part of the page.

Not too sure about that. You are using Wincustomize Forum or Stardock Forum?

Thank you,

 

Basj,

Stardock Community Assistant

Lerem
Reply #2 Monday, April 15, 2019 11:35 PM

I'm using the Wincustomize forum.

I'll try installing DescScapes 10 and I'll report the results.

basj
Reply #3 Tuesday, April 16, 2019 12:16 AM

Not seeing the problem. Just that I need not login. Since every time I goes there I am automatically logged in. Even after manually log off. When I goes again it still logged me in automatically. I am using Chrome btw.

Thank you,

 

Basj,

Stardock Community Assistant

Lerem
Reply #4 Tuesday, April 16, 2019 1:21 AM

I still maintain that the log in / log out button doesn't work on the Wincustomize forums. I get a 404 error when I tried to log out to test the log in button myself.

I installed DeskScapes 10 and made sure to uninstall version 8. This took several restarts, uninstallations, and re-installations.

The DeskScapes window and program acts like it's working, but the situation with the wallpapers has actually gotten worse. I don't even really know how to describe what's going on here. It's also screwing with itself more without my input, just as I'm typing this.

Only the wallpaper covered by the Fences is showing, the rest of the screen is black. The view on the second monitor sometimes consists of the view of the first monitor, but is not properly scaled or aligned with the second monitor.

When I double-click the first monitor to hide and show the Fences, that screws things up even worse. The monitor goes completely black, and I only see spots of the icons when I mouse over them, or click on the fence's titlebar. As mentioned earlier, what's going on here is a sequence of things being screwed up in ways that are complicated and hard to describe.

I'll restart one last time for the night, but this is a heck of a thing

For what it's worth, I'm still only trying to get a different static image on each monitor. I'm not messing with any fancy stuff until I have the basics working.

Edit: Restarting did not help the situation at all.

basj
Reply #5 Tuesday, April 16, 2019 2:03 AM

Please try the purge and reinstall steps mentioned here : https://forums.stardock.com/485954/deskscapes-support-faq#reinstalling

Make sure to re-boot after the purge. Re-install DS10 Beta2. Reboot and retest.

Thank you,

 

Basj,

Stardock Community Assistant

DaveRI
Reply #6 Tuesday, April 16, 2019 2:42 AM

Lerem

I still maintain that the log in / log out button doesn't work

Try the Login link on the left

Lerem
Reply #7 Tuesday, April 16, 2019 12:57 PM

Basj,

I  have used the purge, restarted, installed Deskscapes 10, restarted, tested and did setup, restarted, and tested again.

Things are still not working right. While the problem of the view on the main monitor being irregularly tiled onto the second monitor is gone, I still can't get wallpapers set up on the monitors.

I can manually apply two wallpapers to the monitors, but this makes the icons and fences disappear. When I mouse over the invisible icons, they appear, but disappear as soon as my mouse moves away. When I double-click to show/side the icons, both of the wallpapers turn black. It's like the Fences program works on the same "layer" as DeskScapes. I can't seem to bring the wallpapers back except by restarting.

Restarting now takes upwards of ten to fifteen minutes.


DaveRI,

I'm not 100% sure what you were getting at here, but the login / log off / logout button at the top of the screen is still broken.

The issue is not that I'm unable to log in. I was able to find a workaround via the sign up page, and I'm here now posting.

I'm just bringing attention to a website issue that is hard to notice if you already have a login cookie in. Even Basj, who appears to be doing some branch of technical support, couldn't see the problem with the broken link because his browser's set to automatically log in through other means.


Thanks, everyone, for the replies so far. This has been a surprisingly frustrating and time-consuming bug hunt that I thought would be only a few minutes outside of organizing. I hope I'll be able to apply these lessons when I either get a new desktop, or re-install windows on my current machine.

DaveRI
Reply #8 Tuesday, April 16, 2019 1:01 PM

Lerem

I'm not 100% sure what you were getting at

Merely pointing you to the one that works for me on Chrome   

basj
Reply #9 Tuesday, April 16, 2019 8:35 PM

Lerem

Basj,

I have used the purge, restarted, installed Deskscapes 10, restarted, tested and did setup, restarted, and tested again.

Things are still not working right. While the problem of the view on the main monitor being irregularly tiled onto the second monitor is gone, I still can't get wallpapers set up on the monitors.

I can manually apply two wallpapers to the monitors, but this makes the icons and fences disappear. When I mouse over the invisible icons, they appear, but disappear as soon as my mouse moves away. When I double-click to show/side the icons, both of the wallpapers turn black. It's like the Fences program works on the same "layer" as DeskScapes. I can't seem to bring the wallpapers back except by restarting.

Restarting now takes upwards of ten to fifteen minutes.

Please try the following:

-For Win8/10 Users: Open the Start Screen, and type 'cmd'. Right-click on the search result and select 'Run as administrator' from below.

-For 7 Users: click Start, in the start search field type 'cmd'. Right-click on the search result and select 'Run as administrator'.

-Type: sfc /scannow

-Wait for the scan to complete (this can take several minutes)

Some help on how this looks should you need it:

https://support.microsoft.com/en-us/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system

If the SFC finds errors, but cannot fix them, please also run the following command in the same command prompt window:

dism.exe /online /Cleanup-Image /RestoreHealth

Some help on how this looks should you need it:

https://www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image

The above command should assist with replacing any damaged or problematic system files. Please note, however, since it may require restoring certain files, this process can take some time and you will need to be patient until it has completed.

Please let me know whether this resolves your problem or if you have any additional questions.

Thank you,

Lerem
Reply #10 Tuesday, April 16, 2019 11:46 PM
  • I ran the System File Checker tools
    • Damaged files were found, and were successfully repaired.
  • I rebooted
  • The problem was not fixed
  • I ran the System File Checker tool again.
    • No integrity violations were found

End result: the problems are still the same. I don't think I can detect any actual changes that have happened as a result of the System File Checker tool, though I'm sure it helped with some stuff I can't see yet.

basj
Reply #11 Tuesday, April 16, 2019 11:58 PM

Try the purge and reinstall again. (reply#5) Since now you know that your Windows 10 system without problem.

Thank you,

 

Basj,

Stardock Community Assistant

Lerem
Reply #12 Wednesday, April 17, 2019 12:44 AM

I ran the purge script, but I'm still seeing the "configure DeskScapes" entry in the context menu on the desktop. Loading up the object desktop manager tells me that DeskScapes is not installed.

I'm currently proceeding with installing the DeskScapes beta.

basj
Reply #13 Wednesday, April 17, 2019 12:49 AM

Sometimes you need to run the purge part twice to actually remove it properly. Not too sure why thought. 

Thank you,

 

Basj,

Stardock Community Assistant

Lerem
Reply #14 Wednesday, April 17, 2019 1:02 AM

I ran the purge script, but I'm still seeing the "configure DeskScapes" entry in the context menu on the desktop. Loading up the object desktop manager tells me that DeskScapes is not installed.

I'm currently proceeding with uninstalling the DeskScapes beta, restarting, purging, restarting, purging, restarting, installing, restarting, and then configuring/testing.

Good gravy, that sequence of events seems ridiculous.

Lerem
Reply #15 Wednesday, April 17, 2019 1:33 AM

After running the purge script for the second time and restarting, I can confirm that the context menu on the desktop does NOT have the DeskScapes entry on it. I forgot to check after the first purge's restart, so I can't comment on that one.

I'm installing DS right now. One more restart, then I start testing it out again.

Lerem
Reply #16 Wednesday, April 17, 2019 1:59 AM

On installing DS, the background tiling issue cropped up again.

Restarting now.
The background tiling problem is here. I'm letting the programs load.

Background is black except for the areas covered by the Fences. When the icons on the main monitor turned from normal icons to blank pages, presumably so that the computer can refresh the icons for some reason, the image that was tiled onto the secondary monitor and also the background of the first monitor, also reflected the change. Unfortunately, the image tiled in the second monitor is still blank page icons even after the main monitor's icons were refreshed. Scratch that, it did eventually update.
   
I right-clicked on ProcessHacker in the area of the toolbar next to the clock, and then after a minute or two, both wallpapers on each desktop went completely black. Double-clicking to try bringing the icons back brought up that cluster of problems that makes my desktop almost unusable. [Details not recorded because I tested the wallpaper applications too quickly]
   
On trying to apply a test wallpaper to monitor 1, I got a popup window saying that DS requires the Desktop Windows Manager to be active. I have not gotten any popups like this before. I clicked "Okay" to let DS handle it. Things seemed like they might be working, except for none of the icons or fences being visible on the main monitor (the only monitor where I have icons and fences). I even applied a second wallpaper to monitor 2, but when I double-clicked to hide and reveal the fences/icons, the wallpapers just became black again. Now the wallpaper on monitor 1 only shows through the fences, as though they were a window. Hiding the fences also hides the view of the wallpaper.


Regarding the Login buttons: the login button on the very top of this page links to https://forums.wincustomize.com/494506/wallpaper-on-second-monitor-does-not-load-on-startup# , while the login button slightly lower than it, where DaveRI indicated, links to https://forums.wincustomize.com/signin-oidc.


And with that, I've run out of energy for the night. I don't know what's wrong, but I've done my best so far to follow instructions and document as much of what I was doing as I could. I could probably improve on the documentation part, since I'm spending so much time dealing with these error states.

Let me know how much detail and information you need on your end, and I'll try to accommodate.

basj
Reply #17 Wednesday, April 17, 2019 4:17 AM

Hello,

I have forwarded your problem to Stardock Support team for their assistance. Please keep an eye on this thread for any updates. We appreciate your feedback and patience.

 

Basj

Stardock Community Assistant.

Lerem
Reply #18 Friday, April 19, 2019 7:51 PM

Got it. How will they be contacting me? I haven't received any emails or private messages on my forum accounts.

basj
Reply #19 Friday, April 19, 2019 9:23 PM

They will respond it here... I would like to suggest the cleanboot steps : https://forums.stardock.com/485954/deskscapes-support-faq#cleanboot

Try it and report back.

Thank you,

 

Basj,

Stardock Community Assistant

Lerem
Reply #20 Monday, April 22, 2019 9:40 PM

Oh, wow. I really CAN access these same forums from Stardock instead of only at WinCustomize. The forums themselves seem a bit more polished, so maybe I'll just use the Stardock forum access point instead.

Anyway, a little progress update on what I've been doing in the meantime:

  • I haven't done that cleanboot step yet, but I'll get to that before I do anything drastic.
  • I went around with CCleaner to poke around with any scanned registry values, making sure to not screw with anything I didn't think I understood.
    • That's after reading elsewhere in tech-related websites that CCleaner's registry cleaner isn't necessarily the best thing to use. Broken registry links aren't necessarily something that needs to be deleted. I guess I normally just ran it through and basically let it do it's thing on automatic.
  • I looked through my programs carefully with Revo Uninstaller to uninstall a few things that I know for sure I wasn't using. (The default uninstall step leaves a ton of orphaned and almost empty folders behind whenever I try to get rid of a program.
  • I checked out the "Run on Startup" section to pay more attention to what was automatically starting up with my computer. I enabled some older stuff and disabled some other stuff.
    • Question: I found 2 entries for Fences in there. One for the Local Machine, and one for the Current User. Are there supposed to be two?

I looked through the configuration data for all the programs in Object Desktop. Turns out a ton of them include wallpaper configuration. Is it possible that they were interfering with Deskscapes? I disabled one of the Fences entries, but I just checked the startup menu, and there was a new registry entry, right next to the disabled one. So I deleted the old disabled one, with the end result being that there are now two total Fences startup entries like before.

I've basically been slowly looking at my computer and doing preparation for a reinstallation of windows, to get some of the speed back in it.

I'll go off and do that cleanboot step before commenting here again.

Please login to comment and/or vote for this skin.

Welcome Guest! Please take the time to register with us.
There are many great features available to you once you register, including:

  • Richer content, access to many features that are disabled for guests like commenting on the forums and downloading skins.
  • Access to a great community, with a massive database of many, many areas of interest.
  • Access to contests & subscription offers like exclusive emails.
  • It's simple, and FREE!



web-wc01