Impulse unable to load because off BITS service

Wednesday, April 8, 2009 by neophil78 | Discussion: Stardock Support General

I get a new trouble on a XP SP3 (french) PC:

"Impulse is unable to connect to download service on your computer. PLease ensure the Background Intelligent Service and the COM+ event System service are enabled on your machine and restart Impulse"

 

I checked what was going on with BITS service and effectivly, it can't start (error message is "Impossible to start the service, error 2: file is missing" - which file ????? )

I think it's BITS 2.5 on XP, i tried to reinstall it but Windows tells it can't install it   

P.S: it seem's trouble has comes after using Dial a fix program http://www.softpedia.com/get/System/System-Miscellaneous/Dial-a-fix.shtml (which is supposed to fix some Windows toubles - and for instance reinstall BITS ), with which i repaired the system restore function

 

HELP - HELP - HELP - HELP

 

What can i do  to solve that ?

ZubaZ
Reply #1 Wednesday, April 8, 2009 5:12 PM

Your best bet is to start with a full build of Impulse. - Impulse Client - Full

Also, I looked at your link.  It'sa bit dated and makes references to Win98/Me.  That would make *me* a bit nervous. 

JMB1984
Reply #2 Wednesday, April 8, 2009 5:32 PM

Eek! Unfortunatly some old code still resides in Impulse, even though we no longer use that system. In response to this difficulty you've seen, we've removed it. While we can't put out a new Impulse with this update immediatly, in the next week or so I hope a new full-install from the web will help you out!

karmat
Reply #3 Wednesday, April 8, 2009 5:47 PM

I think I'm having the same problem. I too am on XP SP3. I did the big update of Impulse the other day, got the same message that Neophil got...

"Impulse is unable to connect to download service on your computer. PLease ensure the Background Intelligent Service and the COM+ event System service are enabled on your machine and restart Impulse"

Then my system froze. I did a hard shutdown and when I restarted, everything looked okay. Just now, I started Impulse and installed 'Impulse Dock', restarted my machine. Checked out the newly installed Dock (which is awesome), but then when I went to start Impulse, I kept getting an error message #140362 saying it's encountered a problem and needs to close. It won't open.

So. do you think doing a full-install from the web would correct that. And if so, do I uninstall Impulse first?

neophil78
Reply #4 Wednesday, April 8, 2009 6:01 PM

Your best bet is to start with a full build of Impulse. - Impulse Client - Full

It will repair my Windows BITS service ???

Also, I looked at your link. It'sa bit dated and makes references to Win98/Me.

You mean MY link or Stardock's links to me ?

In fact i used to run Windows 98 when begining to use Stardock stuff (in the very begining of Stardock ) But i'm now running XP since it exist (i still get two old PC's still runing under Windows 98, and if you use it only for web for instance it's pretty good and quiet as quick - even more - than XP )

 

Well as for my trouble, searching the web, (and trying to understand what happend), i've succeed to solve this problem. If it may be usefull for anyone else having it, here's the solution:

- If for any reason you have to use Dial a fix for repairing the System Restore function, (and if you use restoring function) that will erase some historics linked to BITS service and though make it unvaible and corrupted. Then for a reason i don't understand, the function of Dial a fix to reinstall BITS does not give any error message BUT doesn't repair it in reality ...

- Then to repair BITS service, you'll have to choose the "Fix Windows Update" option of Dial a fix and surprisingly (probably by reinstalling dll's and reseting a lot of things ...), BITS service (as well as Windows update) is repared and Impulse is correctly working again

susie56
Reply #5 Thursday, April 9, 2009 12:04 PM

I am having a problem with Impulse. It will not load. I keep getting a message saying "Impulse has encountered a problem and needs to close". I have sent in error reports but not getting any info on what the problem is.

Can someone help me and tell me what to do?

I am running Vista Ultimate

                   32 bit

Wizard1956
Reply #6 Thursday, April 9, 2009 12:25 PM

suzie56, your best bet would be to uninstall Impulse ,run a clean up program like CCleaner and reboot.Then reinstall Impulse from the Link ZubaZ posted in reply #1. Stardock recommendsthat you disable any spyware/AntiVirus apps during the install.

If you tried to install the Impulse dock,please hold off on that as it is causing issues like the one you are describing.

susie56
Reply #7 Thursday, April 9, 2009 12:31 PM

Will try that. I had installed Impulse Dock, so that might be the problem.

Thanks

karmat
Reply #8 Thursday, April 9, 2009 1:39 PM

I'm having the same sort of problems, I emailed Stardock Support and received a reply which I posted in a similiar posting for others to see. If you want to read it, it's Reply #6 at https://forums.wincustomize.com/345605/#2131845.

Please login to comment and/or vote for this skin.

Welcome Guest! Please take the time to register with us.
There are many great features available to you once you register, including:

  • Richer content, access to many features that are disabled for guests like commenting on the forums and downloading skins.
  • Access to a great community, with a massive database of many, many areas of interest.
  • Access to contests & subscription offers like exclusive emails.
  • It's simple, and FREE!



web-wc01